M.2 SSD nem látható probléma

Sziasztok.

Egy új gépnél az ssd-t nem érzékeli a gép, még biosba se, igy sajna csak porfogónak tudom használni.
Aki a gépet össze rakja azt ajánlja h vegyek egy m.2- sata konvertert. Ez megoldás lehet? illetve ez nélkül is meglehet oldani?
alaplap : GIGABYTE GA-B150M-DS3H
ssd : Adata Premier SP550 120GB ASP550NS38-120GM-C M.2

Találtam valamit:
"M.2 szabványú tároló alkalmazása esetén tehát a fentiek értelmében fontos ellenőriznünk, hogy a fogadó notebook vagy alaplap a vele használni kívánt eszközzel azonos kommunikációs csatornát használjon. Önmagában az, ha károsodás nélkül a foglalatba behelyezhető, még nem jelent egyező interfészt, ezáltal működőképességet."
https://prohardver.hu/tudastar/az_m_2_ngff_formatum.html

A lap támogatja elviekben, a probléma az lehet talán a lap leírása alapján, hogy a sata3_0-ba dugta ott nem támogatja az m.2-t. A többi porton igen. próbáld ki.

ui.: nem dugni hanem kiosztani :smiley:
ui2(lehet alap kérdések).: uefire van állítva a bios?AHCI beállítva?(nem ide módban van ugye?)

Áldom a nevetek hogy ilyen gyorsan válaszoltatok, de szerencsére még vissza tudom küldeni a cuccot , és lekérek helyette egy sata3-as ssd-t, nem akarok senkinek plusz szenvedést :smiley:

Elég sokáig elszórakoztam vele mire sikerült megcsinálnom, és ma már arról fut a windows. Az Istenért sem találom a cikket ami segített, de igyekszem leírni amire még emlékszem.
Az biztos, hogy frissítenem kellett a legfrissebb BIOS-ra. Az oldal azt is ajánlotta, hogy a Sata6G_1-be és 2-be ne legyen semmi dugva. Ezt most a saját beállításaim alapján írom :slight_smile:

ez egy leírás, amit anno kb. én is végigszenvedtem, de ma már megy:
1 - Make sure you unplug all SATA and USB drives, the M.2 drive has to be the only drive installed.

2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.

3 - Click on secure boot option below and make sure it is set to other OS, Not windows UEFI.

4 - Click on key management and clear secure boot keys.

5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

6 - Press F10 to save, exit and reboot.

7 - Windows will now start installing to your NVME drive as it has its own NVME driver built in, I don’t think this would work with previous versions.

8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

9 - Click on secure boot again but now set it to WIndows UEFI mode.

10 - Click on key management and install default secure boot keys

11 - Press F10 to save and exit and windows will finish the install.

Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives. Do not put anything on SATA port 1 as this is now reserved for the NVME drive.

I would also recommend installing the Samsung NVME driver at this point to replace the Windows one.

The background here is NVME SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector.

Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module Windows will read and utilize the M.2-specific UEFI driver. 1 - Make sure you unplug all SATA and USB drives, the M.2 drive has to be the only drive installed.

2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.

3 - Click on secure boot option below and make sure it is set to other OS, Not windows UEFI.

4 - Click on key management and clear secure boot keys.

5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

6 - Press F10 to save, exit and reboot.

7 - Windows will now start installing to your NVME drive as it has its own NVME driver built in, I don’t think this would work with previous versions.

8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

9 - Click on secure boot again but now set it to WIndows UEFI mode.

10 - Click on key management and install default secure boot keys

11 - Press F10 to save and exit and windows will finish the install.

Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives. Do not put anything on SATA port 1 as this is now reserved for the NVME drive.

I would also recommend installing the Samsung NVME driver at this point to replace the Windows one.

The background here is NVME SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector.

Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module Windows will read and utilize the M.2-specific UEFI driver.

Ne küldd vissza, ha az alaplapod támogatja ezt az eszközt, akkor meg tudod csinálni. :wink:
Az más kérdés, hogy szükséged van e rá. Mert én pl biztosan állíthatom, hogy nekem nem volt :smiley: :smile:
Előtte sima SSD volt, és ahhoz képest a gyorsulás - azoknál a dolgoknál amire én használom! - kb pont semmi. :slight_smile:

1 Like

Hali!
Az lenne a kerdesem, hogy miert nem bootol be AKASA M.2 SSD PCIe ezzel az ssd vel Samsung 970 EVO 250 GB ? Szeretnék windowsot telepiteni rá, külön az alaplapon nincsen M.2 es foglalat.

Ahhoz hogy PCIe eszközről bootolj, ahhoz BIOS támagtás is szükséges. Egyéb esetben ugyanúgy működik mint bármilyen más bővítő kártya / eszköz és csak OS alól érhető el.

1 Like

És azt meglehet csinálni, hogy a BIOS támogassa?

Ha van hozzá friss BIOS amibe az MSI bele tette, akkor szimpla BIOS frissítés. Ha ez nincs, akkor marad a BIOS modding, bár nem mindegyikbe hegeszthetok be NVMe modulok, AMI BIOS-okra van tutorial, de egyszerű laikusként nem lehet hogy nagy falat. Plusz ha nem sikerül vagy valamiért korrupt lesz a végeredmény akkor hamar nagyméretű levelnehezek lesz az alaplapodbol.

Akkor semmi de kivacsisagból mi az a BIOS modding? amugy a legfrissebb bios van rajta.

Hát mikor te mint végfelhasználó vagy más harmadik fél módosítást végzel az eredeti gyári BIOS-on.

Azert köszönöm a segitséget.

1 Like

Nekem van egy ASUS Q87M-E i5-s gépem 2db pci e foglalattal bele raktam egy nvm m.2 adaptert a pci expresbe amibe samsung evo 980 nand van BIOS nem látja csm nincs a biosomba uefi le frisitve leg utolsó gyárira másik sata nand windows 10-10 alatt látja a pci express -be lvőt meg is tudtam onnan formázni mért nem látjy a biosom a pci-t peddig biosba pci engedélyezve van bios uj verziom
Version
3801
Date
3/22/2019

SOS

Szia! A nevedhez kapcsolódóan légysz ezt fogalmazd újra, írásjelekkel, helyesírási hibák nélkül, mert egy kukkot nem értek belőle.

2 Likes

Én az első pár szót értettem. De a “jóvanazúgy” szakkifejezés, amit az építőiparban hallhatunk, ide is igaz lett. Nem baj, ha szóközöket sem írunk, mert így érdekesebb a rejvény. :grin:

1 Like

Én értem. Nem láttja az m2 ssd-t a biosban.

1 Like

Megvan köztetek a párhuzam, azért érted. :rofl: (félre ne értsd :wink: )
Viszont a SATA, PCIe részét és a win 10-10 részét is meg tudod fejteni?

2 Likes

Egy m2 átalakítót tett a pcie foglalatba és abba ment bele a samsung evo.
A sata csak tipp, de van egy satás ssd is és azt látja és formázni is tudja.

Emlékszel? Csak a kedvedért hagytam meg az apró billentyűket :wink: full szoftverhibás amúgy :smiley:

Spoiler

Ha valakit érdekel ez a “Magyar ékezetes billentyűzet” nevű app. Nem jó. duplán vesz betűket, meg ki is hagy néha.

1 Like

Sejtettem, hogy a teló lesz a ludas. :slight_smile:

Addig értettem én is, de a SATA-t is “sata nand”-nak írja. Az ugye lehet M.2-es is és lehet vezetékes is. Az meg fura, ha a BIOS nem látja az eszközt, de a win igen. Pont mostanában pakoltam be egy Asus Hyper M.2 X16 V2-őt, 970 EVO-val, de azt pl. nem támogatja minden chipset, ha jól láttam. (plusz nekem 3db X16-osom van, így nem felez X8-ra a VGA-nál)
Szóval nem erőltetném abban lapban a PCIe-n keresztüli M.2-est, mert jelentős VGA teljesítményt veszt.

1 Like