Nem tökéletes a stream, mi lehet az oka?


#1

Nem rég vettem egy új számítógépet, és az utóbbi napokban elkezdtem streamelni. Elsősorban csak hobbi szinten.
Azonban nem mindig fut megfelelően. Elvileg mindent jól beállítottam. Ebben a posztban leírom a gépem konfigját, a stream beállításokat, hogy milyen játékot streameltem és miket tapaszaltam. Bármilyen választ/segítséget elfogadok, az utóbbi 3-4 napban elég sok videót megnéztem már témában, de hátha itt is tudnak néhányan segíteni.

PC Config:
CPU: Intel i5 8600k
GPU: Gigabyte Geforce RTX 2060 GB
2x8 (16) GB DDR4 3200 mhz Ram (Hyperx)
ALAPLAP: Asrock z370 killer SLI
TÁP: Seasonic focus plus gold 750W
SSD: SAMSUNG 250GB 860 EVO M.2 SATA M.2 2280 MZ-N6E250BW
HDD: TOSHIBA P300 2TB 3.5" 7200rpm 64MB SATA3
CPU hűtő: Be quiet! dark rock pro 4

Igen tudom, nem i7 vagy jobb processzor, azonban a streamhez NVENC kódolást használok.
Először 1080p 60fps-el streamel próbálkoztam, jelenleg visszavettem 720p 60 fps-re, amit 5000 bitrate mellet streamelek. A keyframe 2-re van állítva a preset high qualityra.
Az én monitorom FULL HD-s, azonban természetesen az output felbontást 720p-re tettem
A streamhez a Streamlabs OBS-t használom.

A játék amivel próbálkoztam egyelőre a Fortnite (kövezzetek meg :smile: ). Stream nélkül a gépem akár max beállítások mellett is hozza a 200 feletti fps-t de a 144-et simán (144hz-es a monitorom). Sőt stream közben is hozta az fps számokat rendesen. Most jelenleg visszavettem mindent alacsony beállításra. Valamivel szebben is megy ki az egész streamelve mint első próbálkozásra. Ám néha, nem olyan szép a kép és előfordulhatnak akadások. Van, hogy a játék fagy be, van hogy a streamlabs jelez valamilyen hibát, aminek következtében le is állítja a streamet.
Megnéztem mennyire terhelődik a gép stream+játék közben és a procinak kb az 50-60%-a van kihasználva, videókártyának szintén, a Ramnak is csak a felét használja. Azonban néha mégis vannak fennakadások. Rengeteg beállítást teszteltem már, de valami probléma mindig van.

Én is tudom, hogy az egygépes streamelés nem a legszerencsésebb, de szerintem azért ez nem egy gyenge vas, ahhoz, hogy ne bírja. Ráadásul nem is a leggépigényesebb játékkal próbálkoztam. E mellett még az Apex: Legendsel szeretnék esetleg kísérletezni.

Framedrop is nagyon minimális volt az 1-2 órás streamek alatt. A netemnek is bírna kéne hiszen, a legnagyobb csomag van jeleneg a háztartásban. A speedtest is 700 és 1000 Mbps közötti letöltési és 300 Mbps feltöltési sebességet mér.

Nem várom el, hogy ez a config minden gamet elvigyen fullon 1080p 60fps streamelés mellet, ezzel én is tisztában vagyok, de néztem kisebb streamereket, akik gyengébb config mellett gond nélkül streamelnek, ezért lehet nálam vannak a gondok, vagy windows, vagy esetleg obs beállításokban.

Ezért is írtam hátha valaki tud segíteni, és köszönöm előre a válaszokat. Tudom kicsit hosszúra nyúlt, ha még így is felmerülne kérdés igyekszem mindent megválaszolni, amit tudok.


#2

Próbáld meg x264-gyel, és adj egy-két magot az OBS-nek állandóra


#3

próbáltam, úgy több száz százalékos skipped frame volt és 100%-on pörgött a proci. Viszont azt nem tudom, hogyan lehet az OBS-nek egy-két magot állandóra adni. Ezt hol tudom beállítani?


#4

Feladatkezelőben


#5

A játék max framerate-jét lelimitáltad? Ha nem, akkor minden erejét arra fordítja, kevesebb marad kódolásra, ergo rosszabb lesz a stream minősége.


#6

Igen próbálkoztam vele, csak nemtudom még mennyire érdemes belőnöm. Maximum ezzel kísérletezem még.


#7

Első körben fixáld le 60-ra, aztán ha minden oké lehet feljebb menni.


#8

Esetleg windows beállításokkal lehet baj (power settings, nvidia control panel), ha a windows által alapból felrakott driver van fent szerintem próbálj meg egyet az nvidia oldaláról, illetve tudnál esetleg screent küldeni az obs beállításaidról? Elsősorban az output, video és az advanced lenne érdekes :slight_smile:


#9

Egyébként hogy is lehet lefixálni 60 ra out-of game? mert én az nvidia beállításaiban nem találtam emg ahol kéne lennie. De biztos én vagyok figyelmetlen


#10

Passz, de in game biztos lehet állítani frame cap-et.


#11

Rivatuner-rel lehet kívülről fps-t lockolni


#12

Most lelockoltam 60-ra majd 144-re az fps-em. Jelenleg úgy látom nincsen gond, már csak annyi, hogy a kép néha eléggé elmosódik, amikor mozgás van a játékban. Gondolom ez egy ennyire pörgős játéknál teljesen elkerülhetetlen. Finomítani lehet esetleg valahogy?
Jah és most 1080p 60 fps-el streameltem, egyáltalán nem érzékeltem semmilyen akadást, a streamben se és a játékomban se. Igaz csak 1 órát nyomtam tesztként.


#13

Azóta lentebb írtam, hogy javult a helyzet sokkal, de itt vannak a képek:



#14

A minél magasabb bitrate segít az elmosódás csökkentésén, de ez persze megterhelőbb is, szerintem 6000-en elég kéne legyen az élvezhető minőséghez.


#15

Plusz legjobb tudomásom szerint a Twitch nem is enged 6000-nél többet, vagy talán a partnereknek igen. Olvastam ilyesmit. Lehet tévedek.


#16

Amit így láttam: profile high-ra raknám, Advancedben a yuv color range-et fullra, de ezek nem kéne, hogy változtassanak a streamen nagyon teljesítmény szempontból. Amúgy eszik a twitch 6000±t is, ha kinyomod az Enforce streaming service encoder settings-t. (+ obs studio támogatja az új nvencet, szerintem az is megérhet egy próbát, beállítások az új nvenc-hez itt: tutorial)


#17

Ma streameltem 1 órát kb. vagy még annyit se, és ismét előbukkant a streamlabs obs-es hiba. Csináltam róla screenshotot is. Ahogy feljön az üzenet leállítja az obs-t szóval nagyon választási lehetőségem sincs. Nem tudom ezt mi idézheti elő, hátha valaki tudja. Maximum megpróbálkozom másik programmal. Egyelőre jobb ötletem nincs.


#18

Megpróbáltál a 6 magból 1-et, vagy 2-őt fixen odaadni az obs -nek? Az biztos sokat segít, játéknak meg bőven elég a 4.


#19

Ez akkor is szükséges ha nem a processzor végzi a kódolást?
Nem állítottam be egyébként, mert nem találtam, de majd megpróbálok utána járni, hogyan lehet.
Az, hogy feladatkezelőben még elég tág volt nekem.


#20

Ha nem a processzor végzi, akkor nem kell. Csak CPU kódolással szebb minőséget kapsz.