Nem tökéletes a stream, mi lehet az oka?


#32

Ha már kamera nélkül is volt bármennyi framdropod, az azt jelenti hogy már a teljesítménye határán használod a gépet. Ergo bármi, ami erőforrást eszik, növelni fogja ezt az értéket. Természetesen a webcam képét is kódolnia kell a gépnek a játék mellett, ez nyilván nincs “ingyen” erőforrás szempontból, tehát várható hogy nőni fog a framedropok száma.


#33

Persze én ezt értem. Csak azért ha az arányokat nézzük nem mindegy, hogy pl. 7 óra alatt volt összesen 400 frame dropom. Vagy 3,5 óra alatt 25 ezer. Tehát semmit se lehet tenni? Azért szerintem még a legnagyobbakkal is előfordul, hogy van néha frame drop. Azt meg is értem, hogy teljesen nem lehet kiküszöbölni, nem is ez a cél.


#34

bitratet lejebb veszed?


#35

Megpróbálom, maximum akkor megint kicsit szétesősebb kép lesz. Azt hittem ez a config elbír egy webkamerát, de ezek szerint nem :confused:


#36

Én megpróbálnám kikapcsolni a kamerán az auto-focust, white balancet, minden amit automatán csinálna. Ennél gyengébb konfigokon is láttam webkamot frame drop nélkül.


#37

A gond az, hogy kb a 100% erőforrást kihasználod. Ergo ha csak 1%-al többet akarsz, akkor máris látod az eredményt. Hiába “csak” 1%.


#38

Pláne ha a webcam meg van fejelve egy greenscreennel, máris többet eszik.


#39

Igen, az tud tovább rontani a helyzeten, de igazából a 100% kapacitás felett minden más csak ront a helyzeten, akár egy-két chrome ablak is.


#40

Amúgy én hol írtam, hogy 100%-on pörög minden? Főleg, hogy eddig semmi ilyen probléma nem volt. Én annyit írtam, hogy eddig volt, hogy 7 órát streameltem és kb. 0.1%-os Frame drop volt ez idő alatt.
Viszont igyekeztem jobban megfigyelni a dolgokat, és a webkamera nélkül is van most valamiért Frame drop. Tehát valami más lehet a dologban. Mondom mindezt ezt úgy, hogy kb. 3-4 hétig semmilyen probléma nem volt ezzel.
Nem csinálok semmit a játékban csak állok pl. a Lobbyban már akkor droppolja a frameket, mindezt úgy, hogy semmi se pörög 60% felett, de legalábbis a 100%-ot meg se közelíti. Lehet ebből egy gép reinstall lesz.
A válaszokat pedig köszönöm. Bármilyen egyéb ötletet szívesen fogadok


#41

Nem írtad, csak ha romlik a teljesítmény a kamera miatt, az valószínűleg azért van, mert már nem bírja azt is kódolni a géped, ergó 100%-on pörög (ahogy azt @meteoric87 is leírta)


#42

Ne haragudjatok de tényleg nem tudom felfogni. Az, hogy egy hosszabb stream esetében nagyon ritkán van frame drop miért jelenti azt, hogy a gépem nem bírja? Akiket eddig néztem mindenkinél előszokott fordulni.
Nem tartom a gépemet rossznak, nem biztos, hogy a legeslegjobb, de gyengébb gépről is szoktak webkamerával streamelni. Nem kötekedni akarok, csak én nem gondolnám, hogy 0.1%-os frame drop eget rengető probléma lenne. Aztán lehet én vagyok a hülye, és akkor már egyből nem bírja a gépem.
Amit most produkál az tényleg nem normális, de többen is mondták különböző helyeken, hogy elvileg ennek simán bírnia kéne, mivel gyengébb configok is bírják. Szóval tényleg nem kötekedek, csak egyszerűen nem értem.
Illetve nálam nem akad a game minden tökéletesen fut. A stream produkál frame dropokat. Viszont akkor erre ezek szerint nincs megoldás, csak ha jobb dolgokat veszek? Mert ezt se tudom elképzelni, vagy akkor milyen config kéne mégis, hogy elbírjon egy 720p60 Fps-es streamet, egy egyáltalán nem hatalmas gépigényű játékot, és még egy webkamerát. Tény, hogy nem i7, de nem hinném, hogy borzalmas a processzorom, és nem a gépemet védem, de igazából már csak ismétlem magam.
Elnézést ha támadásnak veszítek nem annak szánom. Csak próbálok választ találni a problémára.


#43

A twitch szolgáltat adatokat az adatfolyam minőségéről, érdemes lehet megnézni, ha network related ott meglátod


#44

Azóta tesztelgetek, és a webkamera már ki van húzva a gépből, be sincs állítva streamlabsbe, most már anélkül is csinálja. És a webkamera bedugása előtt ilyen nem volt az elmúlt 1 hónapban, de ezt már ugye említettem. Szóval kezdem feladni. Tényleg most már ötletem sincs mi lehet a probléma.
Nektek pedig köszönöm a türelmet! :smiley:


#45

Küldhetnél egy log file-t, abból is lehet okoskodni ki ezt azt. Nekem az segített amikor gondban voltam.


#46

Fps-ed ugyanúgy 60-ra van lockolva?
Gondolom ha nem megy a stream visszaállítod 144hz-re, hátha ez kimaradt, plusz ha drivert frissítesz az is bele tud piszkálni a beállításokba.
Monitor refresht is nyomasd 60 ra, ha max fps-t kézzel nem tudsz beállítani, kapcsolj v-sync-et jobb híján.


#47

Igazából az egész OBS egy vicc. Én 2005-ös játékot streamelnék 720p-be 60fps-sel, de még azt sem tudok, pedig 6 magos 12 szálas streamer processzorom van. (Ryzen 5 1600, 3,2ghz)

Erre fel mikor elindítom x264, azaz procis kódolással a streamet, mind a 12 szál 100%-on pörög, úgy, hogy fast preset-en van beállítva a kódoló OBS-ben. A játék alapból 1% procit eszik, szóval tud érthetetlen dolgokat művelni ez az OBS.

NVENC-ből meg ha a new NVENC-et használom, akadnak a streamek, pedig állítólag ez a hatékonyabb…de ezt OBS fórumon is rengetegen írják, hogy az új féle nvenc kodekkel akad a stream rtx 2080 videokártyán is. A régi NVENC kódolóval meg nem akad a stream, csak egyszerűen rossz a kép, szinte nézhetetlen. Sajnos OBS-sel manapság már hobbiból sem lehet streamelni, mert nem tudsz normális képminőséget produkálni.

Sokan ajánlották nekem, hogy mivel a régi 2005-ös játékot streamelnék, érdemes bekapcsolni valamilyen fps lock-ot rá, hogy ne menjen feleslegesen többszáz fps-sel. Nos hát, mivel ablakban kell streamelnem a játékot, mert tálcára nem lehet lerakni, ezért a vsync kizárva, nem működik, a RIVATunerrel meg mikor lelockolom az fps-t, laggol az egész játék, ilyen 30 fps feeling lesz, hiába lockolom le akár 100 fps-re. Szóval egyelőre elfogadtam azt a tényt, hogy a 250+ ezer ft-ba került gépem nem tud streamelni 720p-ben egy 2005-ös játékot XD


#48

Ha Windows 10-et használsz:
Azt megnézted, hogy ki van-e kapcsolva a játékmód és játéksáv?
Mert az nekem is sokat segített anno.

https://obsproject.com/wiki/How-to-disable-Windows-10-Gaming-Features

A másik ötletem, hogy kapcsold ki a vírusírtódat, és úgy nézd meg, hogy csökken-e az eldobott képkockák mennyisége. Hátha az.


#49

Igen ezeket direkt kikapcsoltam, mert pl Apexet teljesen bezavarta, ha streameltem. Mármint rosszul ment ki a kép. Szóval ezeken túl vagyok és ezt például orvosolták.
Vírusírtó se oldotta meg.
Szerintem egy reinstall kell, ez a webkamera teljesen bezavarta a dolgokat. Létezik, hogy hibás termék? Vagy valami driver nem lett normálisan telepítve hozzá? Ahhoz is mindent letöltöttem már, de volt, hogy csak rosszabb lett. Minden estre ma vissza viszem a terméket.
Videókártya drivernek volt frissítése, lehet az is bezavarta de ez már csak ötletelés.


#50

Biztos, hogy a megfelelő driver lett hozzá felrakva? Logitech oldaláról, a megfelelő operációs rendszerhez valót szedtél le? Ha igen akkor nem tudom mi lehet, esetleg másik USB foglalatba dugni a kamerát? USB 2.0 az ajánlott neki, ne 3.0-s USB-be dugd.


#51

Esetleg egy olyan webcam driver újratelepítést megpróbálhatsz, hogy Revo Uninstaller-rel törlöd a drivert.

Az ötlet innen jött: